@media screen and (min-width: 580px) { .flotantewhatsapp{ display:none; } }

Compartir por WhatsApp

mikrotik-qos-para-optimizar-tu-red

Mikrotik: QoS para optimizar tu red

Mikrotik: QoS para optimizar tu red

Quality of Service (QoS) es una técnica fundamental en la gestión de redes que permite priorizar ciertos tipos de tráfico sobre otros, asegurando que las aplicaciones críticas reciban el ancho de banda necesario para funcionar eficientemente, incluso en redes congestionadas. QoS es esencial en entornos donde se ejecutan múltiples aplicaciones que compiten por recursos limitados de red, como en redes domésticas que manejan streaming de video, juegos en línea, VoIP, entre otros.

¿Qué Aporta QoS?

  1. Priorización de Tráfico: Asegura que el tráfico importante (como VoIP o juegos en línea) tenga prioridad sobre otros menos críticos como las descargas de archivos.
  2. Mejora de la Calidad de la Llamada: Reduce el jitter (la señal de retardo) y la latencia en llamadas de VoIP, proporcionando una mejor experiencia de usuario.
  3. Experiencia de Usuario Mejorada: Aumenta la responsividad de aplicaciones críticas y sensibles al tiempo.
  4. Prevención de Congestión: Gestiona el ancho de banda de forma que se evite la congestión en la red.
  5. Gestión de Ancho de Banda: Controla el uso del ancho de banda por aplicación o usuario, permitiendo una distribución más equitativa de los recursos de red.

Ejemplos de Configuraciones de QoS en MikroTik

Aquí te doy unos ejemplos sobre cómo implementar QoS en un router MikroTik para diferentes escenarios:

1. Priorización de VoIP sobre el tráfico general

Para asegurar que las llamadas VoIP siempre tengan suficiente ancho de banda y una baja latencia, puedes crear una cola simple para priorizar el tráfico de VoIP:

Este comando crea una cola que prioriza el tráfico UDP en el puerto 5060, comúnmente usado por SIP en VoIP.

2. Limitar el ancho de banda para streaming de video

Si el streaming de video consume demasiado ancho de banda, puedes limitarlo para asegurar que otras aplicaciones también tengan recursos suficientes:

Esto limita el tráfico TCP al puerto 1935, utilizado comúnmente por RTMP (streaming de video), a 1 Mbps.

3. Gestión de ancho de banda para invitados

Para una red de invitados, puedes querer limitar el ancho de banda general para evitar que consuman demasiado recurso:

Esto aplica un límite de 2 Mbps para toda la subred de invitados.

Os dejo otros dos ejemplos, uno para Youtube y otro para TikTok. Configurar Quality of Service (QoS) en un router MikroTik para aplicaciones específicas como YouTube o TikTok puede ayudarte a gestionar mejor el uso del ancho de banda y asegurar que otras aplicaciones críticas no sufran de lentitud o interrupciones debido al tráfico pesado de video. Aquí te muestro cómo puedes configurar QoS para estas aplicaciones utilizando reglas específicas en MikroTik.

Ejemplo 1: Configuración de QoS para YouTube

YouTube utiliza principalmente el protocolo HTTP/HTTPS para la transmisión de videos, que generalmente ocurre sobre el puerto TCP 443. Para priorizar o limitar el tráfico de YouTube, puedes usar la capa 7 (L7) o direcciones IP conocidas que pertenecen a YouTube, aunque este último método puede ser menos efectivo debido a la cantidad de direcciones IP que YouTube utiliza.

Paso 1: Crear una Regla de Layer7 Protocol

Primero, crea una regla de Layer7 para identificar el tráfico de YouTube:

Paso 2: Configurar la Cola Simple para YouTube

Luego, usa esta regla L7 para marcar y priorizar el tráfico de YouTube:

Este comando limita el ancho de banda máximo para YouTube a 5 Mbps, asegurando que no consuma demasiado ancho de banda.

Ejemplo 2: Configuración de QoS para TikTok

TikTok, similar a YouTube, utiliza HTTP/HTTPS sobre el puerto TCP 443. Puedes usar una aproximación similar con Layer7 para identificar el tráfico de TikTok.

Paso 1: Crear una Regla de Layer7 Protocol

Define una regla Layer7 para TikTok:

Paso 2: Configurar la Cola Simple para TikTok

Configura una cola para gestionar el tráfico de TikTok:

Esto configura un límite de 3 Mbps para TikTok, priorizando otras actividades más críticas en la red.

Consideraciones Adicionales

  • Monitoreo y Ajustes: El QoS requiere monitoreo y ajustes continuos para adaptarse a los cambios en el uso de la red.
  • Testing: Después de aplicar configuraciones de QoS, es crucial realizar pruebas para asegurarse de que los cambios tengan el efecto deseado sin afectar negativamente otras aplicaciones.
  • Comprensión Profunda: Comprender el tipo de tráfico y su importancia es clave para configurar efectivamente el QoS.
  • Actualización de Reglas: Las direcciones IP y otros indicadores de servicios como YouTube y TikTok pueden cambiar. Es importante mantener actualizadas las reglas L7.
  • Eficiencia de Layer7: El filtrado de Layer7 puede consumir recursos significativos del CPU del router. Es importante monitorizar el rendimiento del router después de implementar estas reglas.
  • Alternativas: Considera utilizar técnicas de priorización basadas en direcciones IP o puertos cuando sea posible, ya que pueden ser menos demandantes en términos de procesamiento.

Implementar QoS en tu red puede marcar una gran diferencia en la calidad de experiencia para los usuarios y en la eficiencia general del uso de la red.

¿Te ha gustado la entrada SÍGUENOS EN TWITTER O INVITANOS A UN CAFE?

El Blog de Negu

Acerca de Raul Unzue Pulido

Administrador de sistemas virtuales e infraestructuras IT, linuxero y entusiasta de la tecnología.

Compruebe también

mikrotik-usar-disco-ssd-en-rb5009-1

Mikrotik: usar disco SSD en RB5009

Mikrotik: usar disco SSD en RB5009 Hoy os vamos a explicar como aprovechar un disco …

2 comentarios

  1. Pedro Morales

    Hola Raúl!
    Muchas gracias por los tutoriales, están muy currados.
    En cuanto al tutorial de “Mikrotik: QoS para optimizar tu red”, ¿cómo meterías una regla igual para priorizar todo el trafico de IPTV? Quiero hacerlo para una conexión a Movistar con triple play. Aprovecho para preguntarte qué tal el rb5009, quería pillar uno para Movistar con IPTV y meter docker.

    Espero que te encuentres mucho mejor y que el susto solo quedase en eso.

    Muchas gracias de antemano!!

    • Gracias Pedro. Ya voy viendo la luz…

      Hay que crear una regla para identificar el tráfico IPTV:

      /ip firewall mangle
      add chain=prerouting action=mark-packet new-packet-mark=iptv-packets passthrough=yes protocol=udp src-address=192.168.10.0/24 dst-port=4000-5000

      Y una vez identificado creamos una cola para tratarlo y darle prioridad:

      /queue simple
      add name=”IPTV Queue” target=192.168.10.0/24 packet-marks=iptv-packets priority=1 queue=default/default limit-at=0 max-limit=20M burst-limit=0 burst-threshold=0 burst-time=0s

      El RB5009 es un mundo de posibilidades, la verdad, yo estoy muy contento. Depende de lo que quieras hacer con Docker, ya que son containers adaptados a RouterOS, no puedes correr cualquier container.

      Salu2

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

6 + doce =

Uso de cookies

Este sitio web utiliza cookies para que usted tenga la mejor experiencia de usuario. Si continúa navegando está dando su consentimiento para la aceptación de las mencionadas cookies y la aceptación de nuestra política de cookies, pinche el enlace para mayor información.

ACEPTAR
Aviso de cookies
Blog Maquinas Virtuales - El Blog de Negu