@media screen and (min-width: 580px) { .flotantewhatsapp{ display:none; } }

Compartir por WhatsApp

citrix-error-con-netscaler-cannot-start-app-o-cannot-start-desktop-4

Citrix Error con Netscaler “Cannot Start App” o “Cannot Start Desktop”

Citrix Error con Netscaler “Cannot Start App” o “Cannot Start Desktop”

El otro día tuve un problema con la publicación de escritorios y aplicaciones bajo Netscaler Gateway. Sólo sobre Netscaler, pero no así si la URL iba sobre Storefront. De primeras, empezamos a revisar si Netscaler estaba bien parametrizado o si había sido modificado. Al no ver señales sobre él, empezamos a ir revisando toda la infraestructura.

¿Qué síntomas nos hemos encontrado?

  • Podíamos hacer login
  • Se “pintan” las aplicaciones y escritorios
  • Error Cannot Start App ó Cannot Start Desktop sobre aplicaciones y escritorio al abrirlos
  • No existían esos problemas sobre Storefront

Después de muchas vueltas encontramos la solución al problema. Hace unas entradas hablábamos como montar Netscaler+HAProxy+Storefront y ha sido este diseño, “medio obligado”, el que me ha jugado una mala pasada:

citrix-error-con-netscaler-cannot-start-app-o-cannot-start-desktop-0

Primero os enseño los errores:

citrix-error-con-netscaler-cannot-start-app-o-cannot-start-desktop-1

citrix-error-con-netscaler-cannot-start-app-o-cannot-start-desktop-2

Para ver alguna señal deberéis ir al visor de eventos de vuestros Storefront. Desde Applications and Services Logs — Citrix Delivery Services, veréis errores con ID 1003, que apuntan a que existe un error entre los Storefront y los Delivery Controller

citrix-error-con-netscaler-cannot-start-app-o-cannot-start-desktop-3

El Event 0 nos da más pistas:

citrix-error-con-netscaler-cannot-start-app-o-cannot-start-desktop-11

Parece que la STA está mal configurada, o al menos apunta a eso. Así que nos conectamos al Storefront o al Citrix Studio y vamos a la sección Stores — Manage Netscaler Gateways:

citrix-error-con-netscaler-cannot-start-app-o-cannot-start-desktop-4

Editamos:

citrix-error-con-netscaler-cannot-start-app-o-cannot-start-desktop-5

Y efectivamente, se ha introducido los nombres mal de los Delivery Controller, así que los storefront no eran capaces de resolver las Secure Ticket Authority (esto haciendo un ping a las máquinas se ve fácil, si está el ping habilitado claro está):

citrix-error-con-netscaler-cannot-start-app-o-cannot-start-desktop-6

Una vez corregidos los nombres propagamos los cambios entre los Storefront. Vamos a Server Group — Propagate Changes:

citrix-error-con-netscaler-cannot-start-app-o-cannot-start-desktop-7

Por las pruebas, parece que mi problema estaba en que Haproxy me mandaba a un Storefront que tenía mal la configuración (en el otro estaba bien) y no se hizo la propagación correctamente.

Pulsamos YES:

citrix-error-con-netscaler-cannot-start-app-o-cannot-start-desktop-8

Pulsamos OK:

citrix-error-con-netscaler-cannot-start-app-o-cannot-start-desktop-9

Y volvemos a comprobar que ya no existen errores en el visor de eventos y que se abren las aplicaciones:

citrix-error-con-netscaler-cannot-start-app-o-cannot-start-desktop-10

¿Te ha gustado la entrada SÍGUENOS EN TWITTER?

¿Te ha gustado la entrada SÍGUENOS EN TWITTER O INVITANOS A UN CAFE?

El Blog de Negu

Acerca de Raul Unzue Pulido

Blogger en “Máquinas Virtuales - El Blog de Negu” | Senior Security Manager (PMP, ITIL) | ProjectManager, SysAdmin & DevOps Enthusiast | Especialista en Virtualización y Sistemas Operativos | VMware vExpert ⭐️ x12

Compruebe también

powershell-citrix-liberar-licencias

Powershell: Citrix liberar licencias

Powershell: Citrix liberar licencias Hoy os traigo un nuevo script, que nos va a permitir …

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

18 − quince =

Blog Maquinas Virtuales - El Blog de Negu